[Internal GEL announcement] Hanging input and output detections on WEKA

Incident Report for Genomics England

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 15:31 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2026 - 13:14 GMT

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 13, 2026 - 12:54 GMT

Update

We have discovered that WEKA is not releasing a lock file because it believes another process is still using it.

WEKA are investigating the connection between the initial process that acquires the lock and the process that terminates but leaves the lock file hanging.

We are actively working with the WEKA team to trace the involved processes.
Posted Feb 13, 2026 - 12:24 GMT

Investigating

We are aware of an issue with hanging input and output detections on WEKA.

The impact is file locks, causing degraded performance.

We are investigating as a matter of urgency.
Posted Feb 13, 2026 - 11:08 GMT
This incident affected: WEKA Storage Platform (WEKA).