Genomics England: Incident Notification

Incident Report for Genomics England

Resolved

SERVICE:
JIRA Service Desk, Confluence and JIRA

SEVERITY:
2

GEL REF:
GEL-307847

DESCRIPTION:
JIRA Service Desk, JIRA and Confluence access issues

SUMMARY OF IMPACT:
Genomics England's JIRA Service Desk and Confluence access is now fully restored following the resolution of the global Cloudflare incident.

We apologise for any inconvenience this may have caused you.
Posted Nov 19, 2025 - 07:26 GMT

Monitoring

SERVICE:
JIRA Service Desk, Confluence and JIRA

SEVERITY:
2

GEL REF:
GEL-307847

DESCRIPTION:
JIRA Service Desk, JIRA and Confluence access issues

SUMMARY OF IMPACT:
Clouflare have implemented a fix which has restored access to Genomics England's JIRA Service Desk and Confluence. We are currently monitoring the applications until Cloudflare services are fully resolved.

All NGIS applications are currently unimpacted.
Posted Nov 18, 2025 - 13:59 GMT

Investigating

SERVICE:
JIRA Service Desk, Confluence and JIRA

SEVERITY:
2

GEL REF:
GEL-307847

DESCRIPTION:
JIRA Service Desk, JIRA and Confluence access issues

SUMMARY OF IMPACT:
We are currently experiencing an outage to Genomics England's JIRA Service Desk and Confluence, which cannot be accessed currently. This is due to the ongoing global outage of Cloudflare.

All NGIS applications are currently unimpacted.

If you want to raise any issues with Genomics England Service Desk on 0808 281 9535 or email ge-servicedesk@genomicsengland.co.uk.
We apologise for any inconvenience this may cause you.
Posted Nov 18, 2025 - 12:04 GMT
This incident affected: NGIS_Production_Environment (General_Service_Updates_NGIS_Production).